Feb 05, 2012
Post id: 309580 Report Item

I'm writting  a maya mocap plugin, after finished it I found that the server started, the device  can connect  with axis and maya attibutes, but no data stream, the object connected with the device didn't move. The script window has no any error messages!  Then I tested the example server "mayaClockServer", I found that sometimes and some machings it worked(the hands rotate), but some times or some machines didn't work (the hands don't rotate), and there's no any error massages. I asked many people ,no one know why!
Any one know it? I will appreciate your help!


Feb 15, 2012
Post id: 309640 Report Item

Did you look at mayaClockDemo.mel and initDataServer.mel and see what is the return value for the proc server()?

My guess is on some machine you might not have the admin permission to communicate through socket. 

Feb 17, 2012
Post id: 309652 Report Item

Thanks! You are right. The reason is the firewall! After close the firewall,my plugin worked well!The firewall block the socket!

Mar 15, 2012
Post id: 309784 Report Item

I've been running into the same issue. My firewall is off, and maya sometimes requests data from the server, but other times it doesn't. It's very annoying. Were you able to figure out why this is happening ?