Underwater lighting - parti_volume

Report this File

Colour_image

Views:

178,910

Updated:

Jul 16, 2010

Readership Level:

Advanced

Tags:

underwater, water, parti_volume, lighting, volumetric, Caustics

Maya Versions:

2009, 2010, 2011

Platforms:

mac, windows

Owner:

Language:

English

In this tutorial we will be exploring the use of the Mental Ray node "parti_volume". in the past this has been somewhat troublesome for new and experienced users alike. however with this tutorial i aim to explain how to set it up in a way that will enable you to go ahead and put it to your own use.

We will also be covering the creation of caustics. Although i will be using it in the situation of moving open water the process of creating them works in any situation that you require caustics.

So lets get going...

Part 1 - Scene Setup

for all of the following make sure Interactive Creation is turned off

1. Create a polygon cube and scale it by 300.

2. Name this Cube "photonBoundry". see figure 1.1

photonBoundry
figure 1.1

3. Create a Polygon Plane and scale it by 60.

4. Name this Plane "seaBed". see figure 1.2

seaBed
figure 1.2

5. Create another Polygon Plane, scale it by 20 and this time translate it by x=10 , y= 17, z=10.

6. Name this Plane "waterSurface". see figure 1.3

waterSurface
figure 1.3

7. Create a Spot Light and rotate it by x=-75, y=50, z=0 and translate by x=15, y=36, z=15.

8. Name this Spotlight "photonEmmitter". see figure 1.4

photonEmitter
figure 1.4

On the next page we will be creating the water surface...

Tutorial_next_page

Comments

Dashboard_avatar
May 28, 2013
Post id: 18003
Report this comment to moderators [SPAM]

Hello, I tried to do your tutorial but something wrong, can you send me your scene?
Email: jsamat68@gmail.com
Thank a lot!

View mantrid's profile
Jul 15, 2010
Post id: 11818
Report this comment to moderators [SPAM]

dunno if I'm doing something wrong, but I followed the tutorial word for word, checked it through several times, but I still can't get the light fog/rays to render. The caustics on the seasbed and water surface are fine, but no light rays. Tried all the normal ways of using fog within the spotlight, and even that doesn't render with this setup.....am I missing something glaringly obvious?

Dashboard_avatar
Jul 16, 2010
Post id: 11825
Report this comment to moderators [SPAM]

Hi Pootang,

If you can upload a copy of your scene somewhere i'll go through it and check. it might be something little or it could be a mistake that ive made in the tutorial.

Firth thing to mention is make sure you are using Mental Ray for rendering as maya software will not work for this effect. in terms of the missing rays it could be a parti_volume issue or even a camera issue. as i sai if you send me the scene i'll have a look and point you in the right direction.

Callum

Dashboard_avatar
Jul 16, 2010
Post id: 11829
Report this comment to moderators [SPAM]

Hi Callum,

Thanks for the tutorial, just what I'm looking for for a project I'm doing. Did you find the solution to Pootang's problem in the end, as I seem to have the same one?

Regards,
Chris

Dashboard_avatar
Jul 16, 2010
Post id: 11830
Report this comment to moderators [SPAM]

I havent heard back from them yet but if you are willing to send me your scene then I will have a look at it.

Callum

Dashboard_avatar
Jul 16, 2010
Post id: 11831
Report this comment to moderators [SPAM]

Think I've found the solution. Nothing wrong with your tutorial, just not quite clear on the diagrams... the Scatter colour on parti_volume1 and parti_volume_photon1 shouldn't be black, but dark grey instead.

Hope this helps anyone.

Thanks again,
Chris

Dashboard_avatar
Jul 16, 2010
Post id: 11832
Report this comment to moderators [SPAM]

ahh I see. yeah by moving the slider to the position indicted it should be the same however I shall make a note on the tutorial so that in future people who are reading will better understand the setup.

I'm glad the tutorial otherwise has been of use.

Callum

Dashboard_avatar
Jul 21, 2010
Post id: 11878
Report this comment to moderators [SPAM]

i can't find "parti_volume_photon1" can you please help me, i followed your instructions tep by step but it seems its not there, what do you think is the problem? Thanks

Dashboard_avatar
Jul 21, 2010
Post id: 11879
Report this comment to moderators [SPAM]

The parti_volume_photon node is a mental ray node that can be found under the “photon volumetric materials” section. its not in the same section as the parti_volume node.

View tyrellcorp 's profile
Jul 21, 2010
Post id: 11880
Report this comment to moderators [SPAM]

sorry wheres this "photonBoundry Cube "?

Dashboard_avatar
Jul 22, 2010
Post id: 11886
Report this comment to moderators [SPAM]

its just a normal polygon cube, that if you have followed the tutorial, you have named "photonBoundry" you will see it in the outliner. its the first cube you created.

View tyrellcorp 's profile
Jul 22, 2010
Post id: 11887
Report this comment to moderators [SPAM]

yeah thanks for that, i wasnt using the 1st page..! just trying to adapt your tut for the scene i was working on .. while i am here, when using photons would putting a cube around any scene create a "boundry" and thus reduce render time?

Dashboard_avatar
Jul 24, 2010
Post id: 11911
Report this comment to moderators [SPAM]

great

Dashboard_avatar
Jul 30, 2010
Post id: 11984
Report this comment to moderators [SPAM]

Got a Little problem here, I can see the light on the seabed and waterbed but no volumetric light visible! Checked all the settings and the color of the photonscatter. Any idea's what might be going wrong?

Dashboard_avatar
Jul 30, 2010
Post id: 11985
Report this comment to moderators [SPAM]

"Now where it says "Phot Volume Shader" click the chequered box and select "parti_volume_photon" from the "Photonic Volumetric Materials" section under the Mental Ray nodes. Again leave the settings alone for the node as we'll set them up later"

Those this mean you create a new parti photon volume in the volumeshader for the camera? Or attach partivolume1 and in then create a photon volume in the partivolume1.

Can't seem to get it right. still no volumetric light visible.

Dashboard_avatar
Aug 11, 2010
Post id: 12117
Report this comment to moderators [SPAM]

Hi, can you send me your scenes? Thank you very much for this tutorial.
Email: tinhnhien@gmail.com
Regards,
Tamu

Dashboard_avatar
Sep 20, 2010
Post id: 12499
Report this comment to moderators [SPAM]

the tutor is helpful, thanks a lot!!!!!

Dashboard_avatar
Oct 10, 2010
Post id: 12710
Report this comment to moderators [SPAM]

I followed the tutorial as u say , but I still can't get the light fog & rays effect in render. The caustics shown on the seabed and water surface are fine, but was no light rays in between. try 2 help me out.

Dashboard_avatar
Oct 11, 2010
Post id: 12713
Report this comment to moderators [SPAM]

Thanks for the tutorial!
pretty sure it worked for me, but its hard to tell because this render time is ridiculous
i've been rendering for over 10 minutes and its only 10% done. I also have a lil creature in the scene but it was created out of one polygon sphere so its hard to beleive that that is slowing it down much
Im using my schools computer:
Intel Xeon, 2.53ghz (2 processors)
windows i7
12 gb ram
quadro FX 1800 graphics card (768 mb dedicated memory)
is there something wrong?
thanks for the help

View tyrellcorp 's profile
Oct 17, 2010
Post id: 12774
Report this comment to moderators [SPAM]

many thanks for the tutorial.

I have a problem with the camera , if its outside the cube boundry the rays render fine but when i move the camera inside the cube they dont any idea why ? and on how to fix it ?

View Cliff St. Hubert's profile
Oct 19, 2010
Post id: 12785
Report this comment to moderators [SPAM]

This was a great tutorial, thanks for this one.

Dashboard_avatar
Oct 25, 2010
Post id: 12844
Report this comment to moderators [SPAM]

hi i try to do the same step i am not getting the out put.......... the fog wave effect is not coming what to do and this is my file.

View ganesh bs's profile
Nov 12, 2010
Post id: 13008
Report this comment to moderators [SPAM]

nice!!! thank you

View Psynchronist's profile
May 31, 2011
Post id: 14609
Report this comment to moderators [SPAM]

Ok I found the problem. I don't recall seeing in your tutorial any instruction to connect "parti_volume_photon1" as the Phot Volume Shader for transmat1SG and and dielectric1SG.

View Psynchronist's profile
May 31, 2011
Post id: 14608
Report this comment to moderators [SPAM]

For the life of me I cannot get the volume rays to appear. I'm not a novice, but I can't discount the possibility that I'm missing a step (I'm doubtful though). I tried to the tutorial over at escapestudios and was able to get the volume ray to come out the other side of the glass sphere, but as soon as I try working with displacement maps I got nothing. Enabling Auto Volume doesn't help either. Can someone diagnose my scene (maya 2011)?

Dashboard_avatar
Dec 10, 2010
Post id: 13257
Report this comment to moderators [SPAM]

hey can u mail the scence@gada_paras@yahoo.com

Dashboard_avatar
Dec 10, 2010
Post id: 13258
Report this comment to moderators [SPAM]

thank u very much, its so helpful.. for me, once again thanks..buddy

Dashboard_avatar
Dec 16, 2010
Post id: 13311
Report this comment to moderators [SPAM]

please send me your scene! thanx maximave@gmail.com

View IRAFK's profile
Dec 27, 2010
Post id: 13400
Report this comment to moderators [SPAM]

ugh. Ive redone the tutorial 2 times now, and my computer keeps locking up and maya isnt responding.

Dashboard_avatar
Jan 26, 2011
Post id: 13627
Report this comment to moderators [SPAM]

great tutorial but this took like 30mins to render iirc, not sure if these settings could be optimised or is that generally how slow all gi stuff is?

Dashboard_avatar
Feb 17, 2011
Post id: 13834
Report this comment to moderators [SPAM]

when you follow the tutorial ,and you set up the camera,the settings is for pesp camera.
you should render it with pesp camera,and get the light fog.

View chokie's profile
Mar 23, 2011
Post id: 14126
Report this comment to moderators [SPAM]

thank you sir, i got this result, great tutorial... thank you. but i cant change this color please tell me..

View potrik's profile
Apr 23, 2011
Post id: 14339
Report this comment to moderators [SPAM]

hey i I followed the tutorial,but at the end i can't get final result in render..can u help me

View Sneha Vane's profile
May 04, 2011
Post id: 14412
Report this comment to moderators [SPAM]

I have followed this Tutorial word by word inspite of that I'm not getting any result. Can You pleaze help me out.

Dashboard_avatar
May 17, 2011
Post id: 14500
Report this comment to moderators [SPAM]

thaaaaaaaaaaaaaaaaaaaaaaaaaaaaaanx. . . . .actually i been lokking for this . . . . now only i got it . . . . .

Dashboard_avatar
May 19, 2011
Post id: 14516
Report this comment to moderators [SPAM]

Just want to say KINDLY PLEASE CHECK THAT "AUTO VOLUME" IS ON IN THE OPTIONS . It may be in 2nd or 3rd Tab. Chk it out it may help...One thing for Sure Volume light take much more time to Render In fact more than FINAL GATHER...So take a separate pass for it.

Hope this help

Dashboard_avatar
Jun 02, 2011
Post id: 14620
Report this comment to moderators [SPAM]

I'm looking for this tutorial for several months. I didn't know about this tut on creative crash. Now I've got it, and I'm going to dive with this all times favorite tutorial. Thanks the author Callum Ridley for your great effort. Keep moving with some more extra ordinary tuts.

Dashboard_avatar
Jul 12, 2011
Post id: 14916
Report this comment to moderators [SPAM]

wonderfull but 1 advice 4m me. Just show the working file images instead attribute editor images.. people easily came to know wen u show the working file images...

thank you

View Darken's profile
Aug 30, 2011
Post id: 15201
Report this comment to moderators [SPAM]

hi callum, great tutorial... but i m not getting any output any lights ... render scene is coming pure black .... can u pls send me your maya scene file so that i can come to know where i am doing wrong....pls ilove this effect... pls send me your scene file at animatornj@gmail.com

View Darken's profile
Sep 01, 2011
Post id: 15216
Report this comment to moderators [SPAM]

hey thanks buddy.... i got that ouput....i made one mistake in the starting... forgotn to unchek that interactive creation in the starting... but getting two different output ... on maya 2012 effect is coming much better than maya 2009 ..... anyways great tutorial man.....pls upload some more tutorials for some other effects.... thanks buddy... :)

Dashboard_avatar
Jan 25, 2012
Post id: 15764
Report this comment to moderators [SPAM]

many thanks for this tutorial, works very well!

Dashboard_avatar
Feb 06, 2012
Post id: 15824
Report this comment to moderators [SPAM]

Callum,

I need to change the scale of the scene but the results are bad. Also, the caustics on my seabed floor are rows of squares and look very artificial. Can I email you my file?

Thanks!! :)

Dashboard_avatar
Apr 17, 2012
Post id: 16193
Report this comment to moderators [SPAM]

How do you save it and see the animation?

Dashboard_avatar
Apr 19, 2012
Post id: 16208
Report this comment to moderators [SPAM]

Anyone know how to save the animation and see it?

Dashboard_avatar
May 28, 2012
Post id: 16419
Report this comment to moderators [SPAM]

Hey Callum

Thanks for the tutorial. However, i am getting problems rendering the scene.. its coming out black. Any ideas what's causing this?

Cheers! :)

View sudhir vaijal's profile
Jul 04, 2012
Post id: 16561
Report this comment to moderators [SPAM]

thanks for tut callum.

Dashboard_avatar
Oct 12, 2012
Post id: 16958
Report this comment to moderators [SPAM]

It looks quite good, but in the end after I add the parti_volume, my computer was unable to render out...I guess this effect must be very expensive to render ha.....

Dashboard_avatar
Oct 13, 2012
Post id: 16962
Report this comment to moderators [SPAM]

hi, like your tutorial, but i dont know how i can get rid of the artifacts on the watersurface (black spots)

Pika :)

View enyon's profile
Dec 22, 2012
Post id: 17287
Report this comment to moderators [SPAM]

Thanks for tutorial. Works well, but did't helped me much. What I am actually trying to do, is volume colored caustics for splashes of water (mesh from nparticles) . I tried even simple cube with dielectric material, but don't seem to have a same effect. I would be grateful for any tip/idea. :)

View vinod singh's profile
Jun 05, 2013
Post id: 18066
Report this comment to moderators [SPAM]

hi guys
I just create under water environment scence in maya.
Now i feel panic how i render it in diffrent layers and passes
I stuck with occlusion pass as it show nothing or black image someone please help me
how i manage render passes for optimal output
:(

Dashboard_avatar
Jun 17, 2013
Post id: 18106
Report this comment to moderators [SPAM]

Hi, at first, thank you so much for this tutorial.

However, I can't get the result as in sample pic. Is it possible for me to ask you to send me your scene file? Please!!

Email : kerokero2d@gmail.com

Thanks in advance.

KeroP

Write a Comment

You must be logged in and have verified your email address to leave a comment. Login or create an account